Microsoft 365 SSO Authentication

Incident Report for TCP Software

Resolved

This incident has been resolved.
Posted Feb 03, 2025 - 08:56 CST

Monitoring

Customers using Microsoft 365 for SSO may experience issues logging in to TCP applications. For details and status updates, please visit: https://portal.office.com/servicestatus
Posted Jan 22, 2025 - 16:08 CST