TimeClock Plus Updates - 7.1.75.2 | Prod37

Scheduled for Aug 5, 22:00 CDT  -  Aug 6, 03:00 CDT

Update

7.1.75.2 updates have been rescheduled for Wednesday, August 5th.
Posted Jul 28, 2026 - 11:05 CDT

Scheduled

We will be undergoing scheduled maintenance during this time.
Posted Jul 22, 2026 - 14:37 CDT
This scheduled maintenance affects: TimeClock Plus Time and Attendance (Prod37.tcplusondemand.com).