TimeClock Plus Automation Service Disruption

Incident Report for TCP Software

Resolved

This incident has been resolved.
Posted Aug 11, 2025 - 18:31 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 11, 2025 - 18:26 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 11, 2025 - 17:28 CDT

Investigating

We are investigating reports of customers experiencing automation service disruption. We are working to identify the issue and the impact across our server fleet.
Posted Aug 11, 2025 - 17:07 CDT
This incident affected: TimeClock Plus Time and Attendance (Prod06.tcplusondemand.com, Prod07.tcplusondemand.com, Prod25.tcplusondemand.com, Prod28.tcplusondemand.com, Prod31.tcplusondemand.com, Prod34.tcplusondemand.com).