TimeClock Plus Application Outage
Incident Report for TCP Software
Resolved
This incident has been resolved.
Posted Aug 15, 2024 - 13:00 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 15, 2024 - 08:39 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 15, 2024 - 07:52 CDT
Investigating
We’re experiencing issues with our TimeClock Plus Time and Attendance application. A subset of users are impacted and our team is actively working to resolve this. We will provide more details as soon as more information becomes available.
Posted Aug 15, 2024 - 07:44 CDT
This incident affected: TimeClock Plus Time and Attendance (Prod02.tcplusondemand.com, Prod04.tcplusondemand.com).