Increased Load Times - Canada
Incident Report for TCP Software
Resolved
This incident has been resolved.
Posted Sep 06, 2024 - 15:42 CDT
Monitoring
Performance appears to have stabilized.
Posted Sep 06, 2024 - 11:31 CDT
Investigating
We are investigating slow load times for Canadian systems.
Posted Sep 06, 2024 - 11:01 CDT
This incident affected: Aladtec Scheduling.