The issue has been identified and a fix is being implemented.
Posted Feb 18, 2026 - 08:32 CST
Update
The TimeClock Plus application performance remains stable. We are continuing to investigate the root cause and will provide further updates as information becomes available.
Posted Feb 17, 2026 - 17:08 CST
Update
The TimeClock Plus application performance has stabilized. We are continuing to investigate the root cause and will provide further updates as information becomes available.
Posted Feb 17, 2026 - 08:41 CST
Update
We are continuing to investigate this issue.
Posted Feb 17, 2026 - 07:58 CST
Update
We are continuing to investigate this issue.
Posted Feb 17, 2026 - 07:40 CST
Update
We are continuing to investigate this issue.
Posted Feb 17, 2026 - 07:08 CST
Investigating
We’re experiencing issues with our TimeClock Plus Time and Attendance application. A subset of users are impacted and our team is actively working to resolve this. We will provide more details as soon as more information becomes available.
Posted Feb 17, 2026 - 06:39 CST
This incident affects: TimeClock Plus Time and Attendance (Prod64.tcplusondemand.com).